• Sign up or login, and you'll have full access to opportunities of forum.

Posting Images

Go to CruxDreams.com

Barbaria1

Rebel Leader
Staff member
I just want to say that I love this image. Barb's expression is perfect - I think anyone would be confused and alarmed to suddenly find themselves inexplicably naked in the middle of a Viking battle.
Here on CF I find that I’m often confused and naked in any number of situations... :confused:
 

malins

Stumbling Seeker
Okay I've had a look at this. The new features in the XF 2.2 post composer are described here - including the new attachment manager:

Other people have had the same problems:
The second report mentions a solution:
The default thumbnail size can be changed in the forum settings (admin required of course)
and then "you need to run the rebuild tool"
... this should be in "Tools > Rebuild caches" in the forum admin, according to the support forum.

This is a job that will take quite a while as the server will have to recalculate all the preview images, it would also increase the disk storage requirements but not by very much. Traffic shouldn't be much of an issue as the CDN will deal with it.
To get a decent display it will probably take at least 200px size.

A Xenforo developer (in the thumbnail quality question above) recommended:

Our attachment thumbnails are 300px. We now recommend a minimum of a 150px-200px thumb size. (There is currently an difference in how 2.2 generates attachment thumbnails that base it on the short edge length rather than the long edge; it's not 100% definitive that this won't change before the stable release.)

The reason for the problem is that the attachment thumbnails are stored on the server's file system in a rather small format but in the attachment preview, they are scaled up by CSS to fill the big boxes. Previously we had a small, but sharp image sitting inside that box.
This shows the effect...

The thumbnail size that CF wants to display:
Screenshot 2020-10-07 22.01.38.png

The actual much smaller size that is available
Screenshot 2020-10-07 22.01.50.png

blowing up those tiny images to the bigger display of course makes them look blurry.
 

poem21045

Tribune
Testing.View attachment 911292 Does this thumbnail appear clear or not? I cannot for the life of me see what the problem is with blurred thumbnails. I have been absent for 3 weeks so it was a surprise to come back to arguments about thumbnails. Somebody please be patient and explain.

"Thumbnails? I can't even see her toenails! I can clearly see other, uh, things, though."

It looks good, melis.
(Sorry--couldn't
resist.)
 

Barbaria1

Rebel Leader
Staff member
Testing.View attachment 911292 Does this thumbnail appear clear or not? I cannot for the life of me see what the problem is with blurred thumbnails. I have been absent for 3 weeks so it was a surprise to come back to arguments about thumbnails. Somebody please be patient and explain.


You have to take care when uploading a file to click on the “insert” button in the upper left hand corner of the image once you have uploaded it, then click on “thumbnail” which appears in the same place. Then hit save and the thumbnail pic will load clearly. That little change came with the latest update.
 

Eulalia

Poet Laureate
Staff member
Testing.View attachment 911292 Does this thumbnail appear clear or not? I cannot for the life of me see what the problem is with blurred thumbnails. I have been absent for 3 weeks so it was a surprise to come back to arguments about thumbnails. Somebody please be patient and explain.
I think the problem people are having is with the 'preview' images that appear with a post if the member has uploaded the image but not inserted it into the post. Before the upgrade, that was just a small square with a number and mini-pic which opened up if you clicked on it. Now it's a big square with a blurry preview. Thus:
 

Attachments

  • 1602359487191.png
    1602359487191.png
    379.3 KB · Views: 18

montycrusto

Slave Trader
I think the problem people are having is with the 'preview' images that appear with a post if the member has uploaded the image but not inserted it into the post. Before the upgrade, that was just a small square with a number and mini-pic which opened up if you clicked on it. Now it's a big square with a blurry preview. Thus:
Exactly, that’s why it affected some members more than others, because people habitually either Insert their thumbnails, or don’t bother. The “don’t bother” brigade had their thumbs turned to blurry mush.
 

poem21045

Tribune
Exactly, that’s why it affected some members more than others, because people habitually either Insert their thumbnails, or don’t bother. The “don’t bother” brigade had their thumbs turned to blurry mush.

Reminds me of how some people will wear a mask properly in public, while others, as you say, "don't bother."

They, also, risk becoming "blurry mush."

:nono::nono::nono::nono:
 

Darkprincess69

High Priestess of Slaanesh
Updates are always supposed to improve things, but all they ever seem to do is break stuff :(
 

Jollyrei

Angelus Mortis
Staff member
Updates are always supposed to improve things, but all they ever seem to do is break stuff :(
One would think. But sometimes the updates are due to issues of compatibility of the software with the server operation, or because of a hardware upgrade, which requires different features to work differently. In those cases, the update is not so much an "improvement" as a matter of maintenance. In this case, the issue with the pictures is, I think, a bit of an inconvenience for those who did not "insert" the pics as thumbnails to begin with, and some people object to their images getting "fuzzy" as a result. This is not a matter of anyone's "incompetence" or attempts to break things, but simply a difference that we will have to get used to. Inserting images as thumbnails (instructions earlier in this thread) solves this problem.

I do not think that any of the moderators (and perhaps even IM) knows exactly what the rationale for this change in the treatment of images was, but it is not something that can be "fixed" - it is simply a new feature of the Xenforo platform.
 
Top Bottom